Selections, Masks, Layer Masks, Even More Info

So, you are making that alpha mask, try this.
after you choose the channel to work on duplicate it

. opacity
ggﬁr.nand “a” -select all blend modes
Command “c” -co layer masks

W, Py alpha masks
Command v -paste

vector masks

Menu -edit - fade - color burn, the blend mode clipping paths

What happens? This works for increasing contrast in the mask

. : groups
Next you can apply a levels or curves adjustment to push it further... gradients
You can explore the minimum or maximum filter to expand or contract the mask.
The last step may be to add a Gaussian blur filter to soften the edge slightly, try .5
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3) WORKING WITH LAYERS
4) MASKING

Layers

Layers are flexible, they allow you to EXPERIMENT and explore.

-You can move them up/down in the layers palette, revealing or concealing image parts
The layer stack

-Shift or reposition the image components with in the canvas

-You can change the layer opacity or blend modes

-You can transform layers

Background Layer
-Do not work on the background layer ever
Duplicate the layer (drag to new layer icon at the bottom
of the layers palette or -mac, command “j” -pc, control “j")
-A background layer cannot support layer masks or blend modes
-You can turn the background into a regular layer by double click-
ing on the layer and renaming in the dialogue box that appears
-You can turn a regular layer into a background layer by To move a layer:
Menu, Layer - New - Background from Layer -Click and hold the layer icon

-Drag the layer up or down



8,000 layers and layer styles is the maximum number available

Layers

Linking Layers

-Temporarily link, hold the shift key while selecting layers they will be highlighted indicating
linked status

-Permanent link while layers are temp linked click the link icon at the bottom of the lay-
ers palette

Transparency in a layer is indicated by a GRID PATTERN

Neutral layers

Fill Layers

Type Layers

-A new layer is created automatically, when you select the type tool and type onto the canvas
-To add texture to a type layer you must rasterize the type. (you cannot go back and

edit the text after it has been rasterized) duplicate the text layer, turn off the original text

layer and the rasterize the duplicate layer, to allow for edit ability later

Layer styles

Name your Layers for easier navigation
-To name a layer, double click on the generic layer name, it will highlight
allowing you to rename.
Color Coding layers and layer groups, when the layer is double clicked a
dialogue box opens you can rename the layer and add a color to the layer

Layer Sets, Groups

Place related layers together in a Set or Group
-A set is a Folder that can be open to reveal all layers or collapsed
revealing only the layer set.
-4 layer sets can be nested inside a set

Creating Layer Groups
1) Select new layer set from the layers palette menu, name the set, drag layers
into set folder
2) Link the layers for the set together, from the layers palette fly-out menu, se-
lect, new layer set from linked
3) Link the layers for the set together, then drag any one to them to create new
layer set button at the bottom of the layers palette
Delete Layer Groups
1) Drag the layer set to the trash can at the bottom of the layers palette
2) Delete layer set from the layers palette menu

Options: cancel operation, delete set but not contents, delete set
3) Command drag control drag, to the trash can in the layers palette will allow
you to delete the set but not the contents



When a layer group is created the blend mode is changed to pass through. This allows the layer set
to interact with layers below

A Layer Group can have a Mask

A mask will mask all of the layers contained in the set

You can,

-Merge visible -any layer that is visible will be merge into one, a visible layer has its
eyeball on

-Merge down -the active layer will merge to the layer directly below
-Flatten layers -all layers will be flattened into one

Do not throw away layers unless they are wrong or unnecessary

Do not flatten unless you are going to print

Layers increase file size...

8bit images

Photoshop just adds the pixel info for each layer

Fill and Adjustment Layers only add 4k-6k to the file size unless you use the mask

16bit images
Any layer doubles the file size in these high bit images

Making Photoshop run FASTER pages 172-173

Allocate as much ram to Photoshop as possible
More ram lets you work faster and more efficiently

Photoshop can address 2 GB of ram
Adobe recommends 3-5 times the amount of ram in relationship to your file.
Back up files regularly
Delete backed up and unnecessary files
Use a maintenance program to defragment the hard drive

Keep only the files you are working on open



Layer Opacity
Layer Transparency
Layer Fill

Used with layer styles, you can reduces the layer opacity while

maintaining the layer style
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Lock transparent pixels, Lock Image pixels, Lock Position, Lock All

Delete Layer

Link  Layer Styles Layer Mask Adjustment Layer Group New Layer

When things are not working

Questions to ask yourself
1) Is the correct layer active?
2) Am I working on the Layer? or Layer Mask
3) Is there an active selection?

mac, Command “D” PC, Control “d”
4) What tool are you using

-what options are set in the options bar?
5) Are you in QM Mode?

when things appear not to be working

STOP clicking, examine what you are doing, evaluate, fix the problem



Smart Objects Julieanne Kost & Daniel Brown e www.adobeevangelists.com

Smart Objects make Photoshop dramatically more flexible by adding nondestructive transfor-
mations. These transformations include but are not limited to scaling, rotating, perspective,
distort, skew, layer styles, and mesh distortions. Non destructive manipulations also include
color conversions, image size, image rotation, etc. Smart Objects can be created from raster
or vector layers from within Photoshop or can reference placed artwork such as a placed RAW
file, EPS, Al, and/or PDF documents.

e To create a Smart Object, select one or more layers and/or groups and select Layer > Smart
Objects > Group into New Smart Object. A Smart Object replaces the layers/groups in the
layer stack with a single reference to the Smart Object; essentially a PSD embedded within
the main PSD.

e Scale the Smart Object up, down, rotate, distort, etc. as many time as you'd like with out
any degradation of image quality because the Smart Object is always referencing the original
layer(s). Hence, you are referring to the original data each time the object is transformed.

e You can also create Smart Objects by selecting File > Place. The placed document is auto-
matically converted into a Smart Object which can be reedited by the originating application
at any time. For example, you may need to work with complex illustrations or logos that are
impossible to copy and paste from Adobe Illustrator into Photoshop (they contain artwork
that would otherwise need to be rasterized by Photoshop to keep the appearance) while
maintaining as vectors. Instead of rasterizing these items, choose to place them as Smart
Objects. Not only can you transform and warp them, you can edit them back in Illustrator or
whatever the creating application was if necessary.

Here are three examples of the power of Smart objects.

e You can create a Smart Object out of multiple raster layers in Photoshop, perform non-dis-
tructive transformations, apply masks etc. If you need to edit the individual layers (perhaps
you need to make some pixel-based edits like use the Healing Brush or color correct an in-
dividual layer that's part of the Smart Object), you can select Layer > Smart Objects > Edit
Contents (or double-click on the icon representing the Smart Object on the Layers palette).
You can then edit the original, independent layers and masks contained within the Smart Ob-
ject in the editing window (which looks and works like a regular document window displaying
layer content in the Layers palette, etc.). When changes are saved, the Smart Object is auto-
matically updated with the re-rasterized version - maintaining any transformations and warps.
o If you select File > Place and select an Illustrator document, the Illustrator document au-
tomatically becomes a Smart Object. If you need to make changes, select Layer > Smart
Objects > Edit Contents (or double click on the Smart Object’s thumbnail icon in the Layers
Palette).

This will trigger Photoshop to launch Illustrator and open a working copy of the artwork.
When saved from the creating application, Photoshop

will replace the Smart Object with the edited content and update the appearance. You can
also copy and paste from Illustrator. By default, the artwork is pasted as a Smart Object
(however, you can select from pasting as a smart object, pixels, path or shape layer). Note:
if you are working in any version of Illustrator prior to CS2, you will need to change the File
Handling and Clipboard preference in Illustrator to “Copy as: PDF and AICB”, (which is now
the default in Illustrator CS2).



e If you select File > Place and select a raw file, Photoshop will embed the raw data together
with the converted pixels as a Smart Object. If you edit the contents of the raw Smart Object,
Photoshop will bring up Camera Raw, allow you to change the settings, and when you click
“Done”, Photoshop will replace the Smart Object with the edited content and update the ap-
pearance.

Additional features

e Multiple instances of the same Smart Object can be created by selecting Layer > New >
Layer Via Copy or by dragging the Smart Object to the New Layer icon at the bottom of the
Layers palette. Editing the contents of any of the instances of the Smart Object will update all
placed instances of that Smart Object.

» To create an “unlinked” duplicate of a Smart object, select Layer > Smart Objects >New
Smart Object via Copy. This copy will reference it's own embedded file. If you edit the con-
tents of the Smart Object only that instance will be updated.

e Select Layer > Smart Objects > Export Contents to export a Smart Object as an indepen-
dent file, saving the original information in the creating applications format, or if there is a
mixture of formats, as a .psb file. Think of .psb is the new .psd - it can do everything .psd can
do, but it's written to do away with limitations that weren't a factor when psd was designed
(principally the 2GB file size limit). Psb files can be opened in Photoshop CS or Photoshop CS2
and can be converted to other formats as necessary.

e You can replace the contents of a Smart Object (Layer > Smart Objects > Replace Con-
tents). This replaces the current file, keeping any transformations applied - including warps!
This is a great way to quickly experiment with different images because Photoshop CS2 will
automatically transform them (although it may distort them if their aspect ration differs).

¢ You can nest Smart Objects (i.e. one Smart Object inside another) but the limits on how
many are unknown.

What are the penalties of Smart Objects.

¢ Using a Smart Object generally means that your document needs to store more data,
though if you create one Smart Object from multiple layers, and then make multiple instances
of it, you're probably saving space (relative to duplicating those layers directly).

¢ Using a Smart Object also means that you can’t make pixel level edits (paint, erase, filter
etc.) directly on the Smart Object layer (although you can certainly edit it's contents by se-
lecting Edit > Contents).

e There might be times when you need the individual items in a Smart Object to blend with
other layers in a file and a Smart Objects isolates the blending of its contents because it be-
haves as one item.

e A rasterized copy of any Smart Objects (including vector artwork from applications such

as Adobe Illustrator) are embedded in .psd and .psb files for backward compatibility (which
could also add to file size).



